Wednesday, December 10, 2008

Errors in Windows Live Writer while publishing blog posts in Blogger

I have long been experiencing many errors while using Windows Live Writer. Sadly, I could not find any support or help from their official site or even from the community forum, Google search too didn't yield any productivity. This trouble is so much tensed that I could not make any newer blog post over months.

publishing post to weblog via windows live writer
1. Publishing post to weblog

Errors in WLW appear frequently whenever any post contain images or media files. In fact, this problem might be persistent with Google's Blogger (blog*Spot) service because I tried to resolve the conflict with other different weblog accounts not only of Blogger but also of WordPress. But nobody seems to be responding to my queries- it's neither Microsoft nor Google. Here are few snapshots and the errors associated, find them around the article. (Unfortunately, I had to publish this post via web interface NOT thru WLW.)

file upload failed in widows live writer picasaweb

2. File upload failed: The remote name could not be resolved 'picasaweb.google.com'

I tried by deleting the Weblog Account associated with the blog and again adding the new account, I tried to change the layout of my blog, I browsed for each and every settings in the blog and the Picasa Webalbums (where the uploads photos reside), I tried by changing the ISP (mode of Internet connection), I even tried in dial up, wireless or broadband, I tried almost everything I could. BUT never could I format my blog-- I never succeeded posting any newer blog posts with associated pics to upload.

file upload failed in widows live writer
3. File upload failed: The underlying connection was closed: the connection was closed unexpectedly.

Finally, I have to use the web interface whenever I use images on my blog posts. If anybody has come across such errors in Windows Live Writer, please comment on this post or give me the link to solve my problem.

error connecting to weblog in windows live writer
4. Error connecting to weblog: An error occurred while attempting to connect to your weblog: The remote name could not be resolved 'www.google.com' You must connect this error before proceeding.

windows live writer has stopped working
5. Windows Live Writer has stopped working.

My final words: Few months back WLW was working quite well for other blogs while I didn't notice such errors- or did I not posted with pics. In all the error cases shown above, my computer was connected to the Internet via 156KBPS and the other time I tried with 256KBPS. Is Microsoft or Google expecting me to have always on corporate T3 lines while uploading few hundred KB pics via WLW? The world is not that easy rather.

2 comment(s):

jcheng said...

Hello, I'm one of the developers for Windows Live Writer. Sorry for the trouble you've been experiencing. These error messages are indicative of network errors and are certainly not what we expect. Do you have any software firewall or download manager software installed?

If not, perhaps you can e-mail your log file (Help | About | Show log file) to joe.cheng *AT* microsoft.com and I can see if there's any other clues there. Thanks.

Help seeker said...

I am too getting similar errors though I have broadband connection and no 3rd party firewalls installed.

Subscribe to Ekendra's feed